Gladly Reports and Insight Builder Data Latency

Incident Report for Gladly

Resolved

Our technology partner has deployed a fix for this issue. Gladly Reports and Insight Builders should be operating as expected again as of 6:09 PM PT.

Please contact gladly support should you have any questions.
Posted Sep 24, 2025 - 18:12 PDT

Identified

We have an identified an issue causing elevated data latency beginning ~4:09 PM PT today on Gladly Reports and Gladly Insight Builder. This issue does not affect the Events API, Webhooks, Liveboards or AWS EventBridge, which continue to function as expected.

Please contact gladly support should you have any questions.
Posted Sep 24, 2025 - 17:39 PDT
This incident affected: Reporting.