Gladly Reports and Insight Builder Data Latency

Incident Report for Gladly

Resolved

Data latency for Gladly Reports and Insight Builder has continued to operate within expected levels.

Please contact gladly support should you have any questions.
Posted Jul 31, 2025 - 13:26 PDT

Monitoring

Data latency for Gladly Reports and Insight Builder has been restored within expected levels. We will continue to monitor.

Please contact gladly support should you have any questions.
Posted Jul 31, 2025 - 12:31 PDT

Update

We are deploying a fix for this issue, and expect data latency for Gladly Reports and Insight Builder to be restored to within expected levels in 60-75 minutes. We will update the Status Page once completed.

Please contact gladly support should you have any questions.
Posted Jul 31, 2025 - 11:32 PDT

Identified

We have an identified an issue causing elevated data latency beginning ~10:30 AM PT today on Gladly Reports and Gladly Insight Builder. This issue does not affect the Events API, Webhooks, Liveboards or AWS EventBridge, which continue to function as expected.

Please contact gladly support should you have any questions.
Posted Jul 31, 2025 - 11:10 PDT
This incident affected: Reporting.