We have confirmed that the issue has been resolved. Reports are loading normally, and we have confirmed stable performance across the reporting service. Thank you for your patience while we worked through this.
Please contact Gladly Support should you have any questions or use this alternative form if you are unable to access the Help page.
Posted Aug 31, 2026 - 20:42 PDT
Monitoring
The issue affecting report loading has been resolved and we are seeing normal performance across the reporting service. We will continue to monitor closely and will provide a final update once we've confirmed the issue is fully resolved.
Please contact Gladly Support should you have any questions or use this alternative form if you are unable to access the Help page. Reporting
Posted Aug 31, 2026 - 20:06 PDT
Update
We're continuing to work with our reporting partner to remediate this issue. We will continue to update the status page very 120 minutes or sooner.
Please contact Gladly Support should you have any questions or use this alternative form if you are unable to access the Help page.
Posted Aug 31, 2026 - 19:00 PDT
Update
We're continuing to work with our reporting partner to remediate this issue. Thank you for your patience.
Please contact Gladly Support should you have any questions or use this alternative form if you are unable to access the Help page.
Posted Aug 31, 2026 - 18:28 PDT
Identified
We have identified the root cause of this issue and are actively working with our reporting partners to remediate. We will continue updating this page every 30 minutes or sooner.
Please contact Gladly Support should you have any questions or use this alternative form if you are unable to access the Help page.
Posted Aug 31, 2026 - 16:30 PDT
Investigating
We're investigating an issue regarding Reports not loading. We are actively investigating and will continue updating this page every 30 minutes or sooner.
Please contact Gladly Support should you have any questions or use this alternative form if you are unable to access the Help page.